vue-awesome-swiper 不兼容ie问题

1.问题原因

vue-awesome-swiper 4.x版本或者更高版本在ie浏览器上会出现swiper轮播出现问题,可以采用vue-awesome-swiper版本降级到3.1.3,vue-awesome-swiper高版本应用了很多es6语法,node_modules文件打包会忽略babel转换

2.解决方案

简单方法1:vue-awesome-swiper版本降级到3.1.3

优化方法2:webpack配置将vue-awesome-swiper加入babel转换中

transpileDependencies: ['vue-awesome-swiper']

版权声明:
作者:wuhou123
链接:https://wuhou.fun/397.html
来源:前端网
文章版权归作者所有,未经允许请勿转载。

THE END
分享
二维码
< <上一篇
下一篇>>
文章目录
关闭
目 录